
XAID:
Software tools for visualization and 

analysis of XAFS spectra 
XAID is a user-friendly package to perform XAFS data analysis. It is intended for visualization, 
averaging, extraction, filtering, etc. of single or multiple sets of raw data. For a more 
sophisticated analysis, including fitting to a model or ab-initio calculations, other codes should 
be used. See the XAFS Software Catalog and chose your preferred code. 

Modules for standard XAFS analysis:

●     XAID_MU2CHI EXAFS signal Extraction 
●     XAID_FF Fourier Filtering 
●     XAID_CALIB Calibration of dispersive XAFS spectra 

Modules for multiple spectra analysis

●     EXODUS Visualization, interpolation, reesampling, averaging, linear combination and fit 
from multiple spectra contained in SPEC data files. This module has been especially 
written for ID26. 

●     DELIA Simultaneous visualization, interpolation, calibration, extraction and Fourier 
filtering on a bunch of spectra (typically dispersive XAFS experiments). This module has 
been especially written for ID24. 

DABAX tools

●     Tables of atomic scattering factors f1 and f2 
●     McKale phases 
●     EXAFS spectra database 
●     XANES spectra database 

Starting the program

http://www.esrf.fr/computing/scientific/exafs/


If you are at ESRF (www.esrf.fr), the programs are installed in the NICE cluster and may be 
accessed by any workstation. For that enter (this command is also good for any Unix 
installation): 
xop xaid
or (in case this fails): 
/sware/exp/xop-2.0/xop xaid
If XAID starts correctly, a window like this one should appear:

From this window you should start the different XAID modules using the Start... menu. 

Installation

XAID can be freely installed in virtually any kind of machine. It is distributed as a part of the 
XOP software package. Two steps must be followes (see XOP website 
/www.esrf.fr/computing/scientific/xop)

1.  Download and install XOP 
2.  Download and install XAID as an "XOP extension" 

Created: 14 April 2000. Last modified: 10 May 2000 
Author: M. Sanchez del Rio (srio@esrf.fr)

http://www.esrf.fr/
http://www.esrf.fr/computing/scientific/xop
http://www.esrf.fr/computing/scientific/people/srio/
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Module XAID_Mu2Chi

Module characteristics

●     Goal: to obtaing the XAFS signam Chi(k) starting from the absorption signal Mu(Energy) 
●     Input: A 2 column file with Mu(Energy) data. It may also receive data from other XAID 

modules. 
●     Output: To a 2-column ASCII file, or passed to the XAID_FF module, or passed to 

XPLOT module for better visualization and further processing, or a combination of them. 
●     Tricks: 

❍     Zoom at any time by selecting a box in the window. 
❍     You may use View->XPlot at any time to get more details on your data. 
❍     It is recommended to display Mu in k scale before starting the post-edge fitting, 

although this is not stricktly necessary. 

Follow the steps

1.  Load a 2-colums ASCII file with input data (Energy in eV in the first column and 
Mu(Energy) in the secondone) by using the File->LoadFile menu. Use for example 
the file: Ge_calib.dat. 

2.  Preparation of the data: you may use the Operation1->Cut item to select the good 
interval for the analysis, or may be Operation1->Interpolation to change the 
number of points. 

3.  Selecting of Eo: using Operation1->Get Eo 
4.  Pre-edge fitting Usually done by fitting the pre-edge with a straight line. Use 

Operation1->Fit Polynomial->Least Squares option for that. If the results of 
the fir is satisfactory, then substract the Fit from the Mu(Energy) signal using 
Operation2->Substraction 

5.  Jump calculation using Operation1->Jump 
6.  Display Mu(k) using the buttons in the lower part of the window 
7.  Post edge spline This is the more delicate part and the quality of your Chi(k) signal 

depens on your ability to perform this fit. It is more an art than a science. Use 
Operation1->Fit Multispline option. The default option may work, but, select the 
minimum of the fit interval around 2 or 3 Angstroms. By default, it presents the full 
interval. A technical trick: negative values are presented (although they do not exist 
physically). This is to obtain smoother fits in the case of selecting the full interval). You 
may use the zoom option (just by selecting the box to be zoomed). Zoom back is done 
using View->Refresh or just clicking on the window. If you do not like this spline, you 
can perform another one by reselecting Operation1->Fit Multispline. If you want 
to carefully study your data and the spline, it is recommended to use View->XPlot 

file:///G|/scisoft/IDL/scisoft/xaid/XAID-HTML/Examples/Ge_calib.dat


option. See an example window. 
8.  Extraction Once you have a satisfactory post-edge spline on the screen, go to 

Operation2->Extraction to obtain the Chi(k) signal. Three options are available, 
that apply different extraction algorithms: 

❍     Experimental: {chi(E)=(mu(E)-mu_at(E))/(mu_at(E)-mu_bck(E)) } 
❍     Constant: {chi(E)=(mu(E)-mu_at(E))/jump} 
❍     Lengeler-Eisenberg: {chi(E)=(mu(E)-mu_at(E))/jump*LE(E)} with LE(E) 
= 1- (8/3) [(E-Eo)/Eo] 

After the extraction you are asked to either substitute or go to XPlot for a better look. 
Click substitute if you are sure you do not want to go back to post-edge spline. 

9.  End After the extraction you can save the result to a file using File->Save File or 
inject the result in the Fourier filter application XAID_FF using Operation1->Fourier 
Filter. In most cases, specially when you have negative k values, it is recommended 
to cut your spectrum to a useful interval before saving. 

FAQs

●     Can I load a scan from a SPEC file in XAID_MU2CHI?
Not directly. You can however open XPlot (e.g., Tools->XPlot, load your SPEC data 
file in XPlot, and start XAID_MU2CHI with your selected scan from the XPlot 
Calculations->XAFS->Xafs Extraction (xaid_mu2chi) 

●     Do I need to follow literally the given steps?
No. But you need some logic in your analysis: in a widget application you risk to get any 
bad result or even crash the program because the combination of different possible 
actions is close to infinity and the author does not have the time to check all of them. 

●     What do the strange labels "Operation 1" and "Operation 2" in the menu bar 
mean?
"Operation 1" refers to operations with a single data set (i.e., when you see only a line in 
the graphical window). "Operation 2" refers to operations between two data sets (two 
lines displayed). 

Window example

This is the window (zoomed) at the step 7 using the example data file and performing the post-
edge spline starting at 3 A. 



[Back]



Module XAID_FF

Module characteristics

●     Goal: to calculate the Fourier Transform (FT) of a XAFS spectrum Chi(k) and the Back 
Fourier Transform (BFT) of a selected region of the FT. Chi(k) can be weighted with 
powers of k (from 0 to 4) and many weighting windows are available. 

●     Input: A 2 column file with Chi(k) data. It may also receive data from other XAID 
modules. 

●     Output: A SPEC-formatted data file with signal, FT and BFT (Use File->Save File). 
●     Tricks: 

❍     After changing any parameter, press "Enter" to refresh calculations. 
❍     The syntax of the intervals is: [min,max]. The square brackets and the separating 

coma are must always be entered. 

Follow the steps

1.  Load a 2-colums ASCII file with input data (k in A in the first column and Chi(k) in the 
secondone) by using the File->Load File menu. Use for example the file: 
Ge_calib.chi. 

2.  Input: 
❍     The k limits for the FT (in left window) 
❍     The R interval in central window (limits for the FT plot). 
❍     The R limits for the Back Fourier (in central window). The BFT is calculated from 

the FT within these limits in R. The selected limits appear as vertical lines in the 
FT window (central window). This helps to select more accurately the wanted 
limits, normally including one or several peaks in the FT. 

❍     The k limits for the congugated variable (BFT in the right window). Note that this 
interval must be smaller than the "k limits for the Fourier Transform" interval in the 
left window, otherwise some numerical inconsistences appear. 

❍     The "Shell radius rfor the back phase". This affects only the BFT phase. The BFT 
is written as A(k)*sin(2kr+Phi(k)). The phase is Phi(k). 

3.  Press Enter for calculating and updating the windows after entering any new 
parameter. See an example window. 

FAQs

●     Can I load a scan from a SPEC file in XAID_FF?
Not directly. You can however open Xplot (e.g., Tools->Xplot, load your SPEC data 

file:///G|/scisoft/IDL/scisoft/xaid/XAID-HTML/Examples/Ge_calib.chi


file in Xplot, and start XAID_FF with your selected scan from the Xplot Calculations-
>XAFS->Xafs Extraction (xaid_ff) 

Window example

(click on the image for full resolution) 

[Back]

file:///G|/scisoft/IDL/scisoft/xaid/XAID-HTML/Figures/xaid_ff.jpg


XPLOT 
XPLOT is the common visualization tool for most XOP applications. A manual for an older 
version is available at: http://www.esrf.fr/computing/scientific/xop/xplot/ 

[Back]

http://www.esrf.fr/computing/scientific/xop/xplot/


Module XAID_CALIB

Module characteristics

●     Goal: to calibrate a XAFS spectrum Mu(x). Calibration is done by calculating 
Mu(Energy), where the energy is calculated as a second degree polynomial in x. In other 
words, this module helps in finding the a,b,c coefficients in:
Energy_eV[i] = a+b*(x[i]-x[0])+c*(x[i]-x[0])^2 
being i the index of the i-th point. (The substraction of x[0] is essential for TurboXAS 
experiments performed in ESRF/ID24 beamline). 

●     Input: Two files: 
1.  A 2 column file with calibrated spectrum (reference file) Mu(Energy_in_eV). 
2.  A 2 column file with spectrum to calibrate Mu(x). 

●     Output: The a,b,c coefficients (displayed in main window). 
●     Tricks: 

❍     Remember you always move the dashed (calibrated) plot, and the continous 
(reference) remains fixed. 

Follow the steps

1.  From the main window (see Example window 1), Load two files, the first one with the 
reference spectrum and the second other with the spectrum to calibrate. As examples, 
use the files Ge_calib.chi and Ge_calib.chi, respectively. Once both spectra are loaded, 
an auxiliar XPLOT window (see Example window 2) appears. An estimated a value 
appears automatically. 

2.  Change b manually with the expansion compression value. In the example, I estimate 
that the dashed spectrum must compress at least 20 times to fit the solid one, so I put 
.05 in b and then I do not forget to press ENTER for refreshig the plot. 

3.  Change a manually to a better estimation. You can estimate the value that the edge of 
the dashed (calibrated) spectrum must move to align to the continuous (reference) 
spectrum by using the (x,y) cursor position in the XPLOT window. In the example, I 
estimate that it should be moved 200 units (11100-10900) to the right, so I changed a 
from 10800 (initial guess) to 11000. And then I do not forget to press ENTER for 
refreshig the plot. 

4.  Then I click on the a button, and fine tunning the a value using the "<<" and ">>" buttons. 
You may change the step of the movement. 

5.  Then I click on the b button, and do the fine tunning. I may neede iterating a and b 
tunning. It may also be necessary to use the non-linear term c. 

6.  Occasionaly, the heigth of the twe spectra is different avoiding a good overlapping. For 
that you can expand the Y axis using the value "Expansion ratio of Y axis". This helps in 

file:///G|/scisoft/IDL/scisoft/xaid/XAID-HTML/Examples/Ge_calib.dat
file:///G|/scisoft/IDL/scisoft/xaid/XAID-HTML/Examples/Ge_tocalib.dat


the fine tunning but does not affect the resulting coefficients. 
7.  A calibration (not exceptional) is shown in example window 3. 

Window example

Window 1: Main window after loading the two example files. 

Window 2: XPlot auxiliar window after loading the two example files.
(click on the images for full resolution)



Window 3: XPlot auxiliar window with a result of calibration process. 

file:///G|/scisoft/IDL/scisoft/xaid/XAID-HTML/Figures/xaid_calib_xplot1.jpg
file:///G|/scisoft/IDL/scisoft/xaid/XAID-HTML/Figures/xaid_calib_xplot2.jpg


FAQs

●     May I zoom the image and fix the limits to the zoomed area?
Yes. Just select the wanted area to zoom, click the Zoom button and go to Edit-
>Limits->Set Limits as Selection Area. The next plots will be displayed in the 
selected area. To go back to the defaults, go to 

[Back]



Module EXODUS (EXafs Of DilUte Samples)

Module characteristics

●     Goal: to load a SPEC file and selecting, viewing, averaging, and perform operations with data from 
multiple scans. This applications has been designed for the particular needs of the ESRF/ID26 
beamline. However, it can be useful for any data analysis involving manipulation with data from 
several scans from a single or multiple SPEC data files. 

●     Input: A SPEC file (use Import->SPEC file) 
●     Output: The results of the operations performed with EXODUS can be injected into other XAID 

applications, into XPlot, and they can also be written to a file (ASCII, SPEC or DELIA format). 
●     Tricks: 

❍     Multiple selection: for exploiting all the possibilities of EXODUS, it is essential to know how to 
select multiple lines in the lists. Click on a line for a single line selection. Then press Shift and 
click on another line on the same window (while Shift is pressed) for selecting a block of 
lines. For selecting multiple individual lines use Control instead of Shift. 

Follow the steps

1.  Import a SPEC file The list of scans appears in the left window. 
2.  Copy from left (import) window to right (process) window the data to be processed 

❍     Several controls in the left panel allows you to identify the scans you want to use and their scan 
columns. 

■     View Scan button allows to display the header and/or data of a single scan. You can 
visualize other scans by either using the View Scan button in the left panel of the main 
EXODUS window or by using the Scan Sel... button in the created window containing 
the scan. 

■     Plot Scan button allows to plot a single selected scan. The XPlot window helps in 
identifying the wanted columns. Double-clicking in a scan line has the same effect as 
selecting it and the pressing Plot Scan. 

❍     When you identify a single or multiple scans containing the data you want to use (process), 
then fill the wanted columns in the Cols X and Cols X boxes, select the multiplication factor 
of the X column to obtain X in eV (e.g., use X*1000 if the scan energy is in keV) and press the 
=> button in the central panel. With this, your selected data is copied to the right panel 
(processing area)
Use *=> button if you want to copy all the scans (independently of the selection). If you want to 
process data included in several SPEC files, then Import->SPEC file the next file and 
repeat the process. The data copied to the right window is not deleted when other files are 
imported. 
The example window 1 shows the look of the window after the two first steps. 

3.  The right (process) window allows different operations: 
❍     Visualization of a single data set: select a single line and press Plot button (the same effect 

os obtained by double-click on the data line). The data is sent to an XPlot window for 
visualization. You may use all the features of XPlot for analysis. 

❍     Visualization of multiple data set: select several lines (using Shift+click or/and 
Control+click) and then press the Plot button. An "EXODUS multiple plot" window appears 

http://www.esrf.fr/exp_facilities/ID26/handbook/handbook.html


containing an overplot of all data sets. You can zoom a selected region just selecting the 
wanted region with the mouse (use Zoom Out button or just click on the graph to zoom back). 
This window also allows to display the different spectra shifted vertically one respect to the 
other. For that press Edit Parameters button, select a "Shift spectrum factor" different from 
zero (zero means no shift, one means shift a distance equal to the height of the first displayed 
spectrum). Then press Accept and a shifted plot appears. 

❍     Delete the data sets: use the Delete button to delete the currently selected data sets, or use 
the *Delete button to delete everything. 

❍     Edit labels use the Edit:->Title option to change the labels of the data sets for a more 
meaningful text. 

4.  Operations with data sets in the right (process) panel. This is the most important part in processing 
your data with EXODUS. It allows you to perform a selected operation (interpolate, average, sum, 
perform a customized operation and fit a linear combination) on the selected data sets: 

❍     Operations:->Interpolation This option builds interpolated or resampled data sets from 
the selected ones. The interpolated/resampled data sets will have the same abscissas array. 
The abscissas array can be selected between different options: i) like the first data set, ii) 
customized with constant step in Energy scale, and iii) customized with constant step in k 
scale. The results can be added to the list of data sets (right panel) or be injected in XPlot for 
visualizing in 2D (multiple column format) or in 3D. You may want to save the results in XPlot to 
a file using XPLot->File->Write ASCII file with current set... option. 
Two algorithms are available: 

■     Interpolation: linear interpolation. The y value for the new x value is calculated by linear 
interpolation between the two closer neighbours. This option is recommended when the 
number of points of the interpolated array is of the order or bigger than the number of 
points of the original array. 

■     Resample: Some kind of smooth interpolation. For each resampled point x[i] of xNew it 
calculates yNew consisting in the average y values of all points (x,y) sitting in the interval 
[x[i]-0.5*step1,x[i]+0.5*step2], with step1=x[i]-x[i-1] and step2=x[i+1]-x[i]. In the case that 
step1 or step2 are undefined (first and last points) we used step=[x[1]-x[0]] instead step1 
or step2. 

❍     Operations:->Interpolation This option averages the selected data sets. For that, if the 
abscissas are different, it makes an interpolation (see before). The result is added to the list in 
the right panel. 

❍     Operations:->Sum This option sums the selected data sets. For that, if the abscissas are 
different, it makes an interpolation (see before). The result is added to the list in the right panel. 

❍     Operations:->Customized This option allows you to program a customized operation. The 
result is added to the list in the right panel. 

❍     Operations:->Fit LinCom This option allows you to perform fit a given data set in the list 
(target) as a linear combination of other data sets (components) in the list. This option is useful 
whilst analyzing XANES spectra of compounds or mixtures, and wanted to know the percent of 
its components. The data sets to be used as target and components are identified by their 
indices in the right panel list, starting from zero. If the list is long, you may want to use the 
View:->Info option to help in identifying the indices of the wanted data sets. The fit is 
performed using the Levenberg-Marquardt [MINPACK-1] method as implemented in the MPFit 
IDL routine. The result of the fit is added to the right panel list. 

5.  Export options: the data sets in the right panel list can be exported to other applications (like 
XAID_MU2CHI or XAID_FF) or to a file in the following formats: 

❍     ASCII file a file containing two columns and an optional commant line. Only a single data set 
(not multiple sets) can be stored in an ASCII file. 

http://cow.physics.wisc.edu/~craigm/idl/idl.html


❍     SPEC file The selected data sets are written to a new SPEC file or added to an existing SPEC 
file. This option is particulary useful to save some kind of workspace of the current work: just 
select all data sets in the right panel and save to a new SPEC file. The resulting file can then be 
imported in a new EXODUS session. 

❍     DELIA file The selected data sets are written to binary file in DELIA format. Note that this 
option does not save the labels. The data sets will be indexed in the DELIA file as they appear 
in the right panel. 

FAQs

●     Can I do other operations like spline, convolution etc. on the spectra?
Yes, but on a single spectrum. Just double click on the data set line in the right panel, and use the 
Caluclations menu in the XPlot winwdow. 

Window examples

Window 1. Status of the EXODUS window after steps 1 and 2. 



[Back]



Module DELIA (Dispersive Exafs 
caLIbration and Analysis)

Module characteristics

●     Goal: To perform operations over a bunch of spectra. Operations: calibration the 
spectra, extraction of the XAFS signal and Fourier (and back-Fourier) filtering. This 
applications has been designed for the particular needs of the ESRF/ID24 beamline. The 
Dispersive XAFS and Turbo-XAS techniques generate a huge amount of XAFS spectra 
in few seconds or minutes. This module allows the user to visualize the spectra, calibrate 
them, extract the XAFS signal and perform Fourier and back-Fourier transforms 
simultaneously over all the spectra by simply point-and-click. 

●     Input: a file with raw data. The standard input file contains three columns with X,Mu and 
Index, all floats, written in binary format by a big endian system. The file size is then 
number_of_points*3*8 bits. Note that you can run DELIA in both little or big endian 
systems, but the file must be written by a big endian system (or also by a little endian 
system but swapping the byte ordering). To load a standard raw data file use the 
Browser... buttin in the "Raw" control panel. 
DELIA also accepts other ASCII input files (using the File menu: 

❍     ASCII RAW data: a multicolumn file containing at least three columns (more 
columns also accepted) with X,Mu and index. The index can be any value that 
identify the spectrum. Usually indices are 0,1,2..., but can be, for example, a 
temperature value, etc. 

❍     Mu(E): a multicolumn file containing in the first column the Energy values in eV, 
and then one additional column for each spectrum (Mu(Energy)) value. When this 
kind of file is used, the interpolation and calibration analyses are skipped. 

❍     Mu(E): a multicolumn file containing in the first column the Chi values in A, and 
then one additional column for each spectrum (Chi(k)) value. When this kind of file 
is used, the interpolation, calibration, and extraction analyses are skipped. 

●     Output: The results of the operations performed with DELIA can be saved in either 
multicolumn ASCII data files or in sequential ASCII data files. They are usually saved 
from an XPlot window using the menu File->Write ASCII file with current 
set.... 

●     Tricks: 
❍     Better use binary raw input files: they are smaller and load quicker. 

Follow the steps

The DELIA analysis is done in four main steps, Each step is implemented in a different panel in 

http://www.esrf.fr/exp_facilities/ID24/handbook/handbook.html


the main window: Raw, mu(E), chi(k) and Fourier. You should pass from one panel to the 
next one after completing the operations in the current one. The names are self explanatory: 

1.  Phase I [Raw]: allows to read raw data, visualize the individual spectra, overplot them. 
The user must identify the columns with X, Mu and indices. Using the ASCII raw sample 
file f29 I obtained the sample window 1. 

2.  Phase II [mu(E)]: Interpolation and Calibration. It allows the user to input the 
parameters. Default parameters for the interpolation limits are presented. The minimum 
correspond to maximum value between all the abscissas spectra minima, and the 
maximum corresponds to the minimum between all abscissas maxima. They may be 
changed by the user. The user should also supply the calibrating coefficients a,b,c. By 
using the Get... button, the XAID_CALIB application is started to help in finding the 
coefficients. The coefficients found in this way are automatically transferred to the DELIA 
window. Once all parameters are filled, predd the RUN interpolate & calibrate 
button to make calculations over all spectra. The results appear in the "Result:" text 
window and also in a newly created XPlot window. The results can be visualized using 
the 2D and 3D buttons. 
If you want to create a file for further use with DELIA, press the 2D button, and from the 
XPLot window, select File->Write ASCII file with current set..., select 
then Data to save: All columns and Include header (SPEC type): No. 
The resulting file can then be loaded using the DELIA File->Load file with 
Mu(E)... menu. Some example windows are in windows 2 and 3. 

3.  Phase III [chi(k)]: extraction of the XAFS signal, i.e., calculate Chi(k) from Mu(Energy) 
over all the spectra. For selecting the appropriate parameters for the extraction, the user 
must perform interactively the extraction on a single spectrum (select its index and then 
press the Go button to start XAID_MU2CHI module (remember to perform the extraction 
in k space). The parameters of the extraction are copied automatically to their respective 
boxes. The results can be visualized in 2D or 3D and saved to a file for further use in 
DELIA as shown in Phase II. See examples in windows 4 and 5. 

4.  Phase IV [Fourier]: Fourier transform and filtering. As in the previous phase, the user 
must first perform the Fourier Filtering on a single Chi(k) spectrum, by using the 
XAID_FF module. The parameters are copied automatically. A sample can be found in 
window 6 and 

FAQs

●     What to do if the programs crashes?
Restart from scratch. 

Window examples

file:///G|/scisoft/IDL/scisoft/xaid/XAID-HTML/Examples/f29


Window 1. Main panel after loading the ASCII raw data file f29. 

Window 2. Main panel after interpolation and calibration (Phase II). 

file:///G|/scisoft/IDL/scisoft/xaid/XAID-HTML/Examples/f29


Window 3. XPlot window after interpolation and calibration (Phase II). 
(Click on the image for full resolution.) 



Window 4. Main DELIA window during XAFS extraction (Phase III). 

file:///G|/scisoft/IDL/scisoft/xaid/XAID-HTML/Figures/phase2_xplot.jpg


Window 5. XPlot window after XAFS extraction (Phase III). 
(Click on the image for full resolution.) 



Window 5. Main DELIA window during Fourier Filtering (Phase IV). 

file:///G|/scisoft/IDL/scisoft/xaid/XAID-HTML/Figures/phase3_xplot.jpg
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